aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index a60d11793a50..dac32b9cdd76 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -653,7 +653,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
foreach(variableName ${variableNames})
if(variableName MATCHES "^BOOTSTRAP_")
string(SUBSTRING ${variableName} 10 -1 varName)
- string(REPLACE ";" "\;" value "${${variableName}}")
+ string(REPLACE ";" "," value "${${variableName}}")
list(APPEND PASSTHROUGH_VARIABLES
-D${varName}=${value})
endif()
@@ -669,7 +669,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
if("${${variableName}}" STREQUAL "")
set(value "")
else()
- string(REPLACE ";" "\;" value ${${variableName}})
+ string(REPLACE ";" "," value "${${variableName}}")
endif()
list(APPEND PASSTHROUGH_VARIABLES
-D${variableName}=${value})
@@ -697,6 +697,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
USES_TERMINAL_CONFIGURE 1
USES_TERMINAL_BUILD 1
USES_TERMINAL_INSTALL 1
+ LIST_SEPARATOR ,
)
# exclude really-install from main target