aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-11-29 00:23:10 +0000
committerPetr Hosek <phosek@chromium.org>2017-11-29 00:23:10 +0000
commiteba57ead78584274a675537ee39f6eb202f542de (patch)
tree78bdf8be44a3e42af9e6803179bb9879462fe621 /clang/CMakeLists.txt
parent4c1fa685908b90bdde7b2d681b6f0e4dca600d13 (diff)
[CMake] Use LIST_SEPARATOR rather than escaping in ExternalProject_Add
Escaping ; in list arguments passed to ExternalProject_Add doesn't seem to be working in newer versions of CMake (see https://public.kitware.com/Bug/view.php?id=16137 for more details). Use a custom LIST_SEPARATOR instead which is the officially supported way. Differential Revision: https://reviews.llvm.org/D40257 llvm-svn: 319264
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index a60d11793a50..dac32b9cdd76 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -653,7 +653,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
foreach(variableName ${variableNames})
if(variableName MATCHES "^BOOTSTRAP_")
string(SUBSTRING ${variableName} 10 -1 varName)
- string(REPLACE ";" "\;" value "${${variableName}}")
+ string(REPLACE ";" "," value "${${variableName}}")
list(APPEND PASSTHROUGH_VARIABLES
-D${varName}=${value})
endif()
@@ -669,7 +669,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
if("${${variableName}}" STREQUAL "")
set(value "")
else()
- string(REPLACE ";" "\;" value ${${variableName}})
+ string(REPLACE ";" "," value "${${variableName}}")
endif()
list(APPEND PASSTHROUGH_VARIABLES
-D${variableName}=${value})
@@ -697,6 +697,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
USES_TERMINAL_CONFIGURE 1
USES_TERMINAL_BUILD 1
USES_TERMINAL_INSTALL 1
+ LIST_SEPARATOR ,
)
# exclude really-install from main target