aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-12-22 01:32:51 +0000
committerdcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-12-22 01:32:51 +0000
commit537948d5a302fe93c7047e381992a0a168743fa7 (patch)
tree0167c354ab4138b744a199f2e29e9e8f3beedb9d /Makefile.am
parent68bdc04b124846f28f6ca0ee651e328a632762a9 (diff)
Add a "quicktest" pseudo-target, for those times when you just don't want to sit through 11 iterations of TJUnitTest.
git-svn-id: svn://svn.code.sf.net/p/libjpeg-turbo/code/trunk@1465 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b32a41b..772d48a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -262,7 +262,7 @@ MD5_JPEG_CROP = b4197f377e621c4e9b1d20471432610d
endif
-test: testclean all
+test: quicktest
if WITH_TURBOJPEG
if WITH_JAVA
@@ -280,6 +280,8 @@ endif
./tjunittest -yuv -noyuvpad
endif
+quicktest: testclean all
+
# These tests are carefully crafted to provide full coverage of as many of the
# underlying algorithms as possible (including all of the SIMD-accelerated
# ones.)