aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2013-06-28 13:26:03 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-06-28 14:08:48 -0400
commit9fe09ac859dc1371a1a95f219c100d905e6f128d (patch)
treee83aef5299f4c7ec0bbe6e5d23120016fb4ca5d5
parenta668e81713c0cf7c25b89beb9837fa83355b130c (diff)
libvirt: make ebtables a PACKAGECONFIG
This is a bit ugly since ebtables isn't controlled via --with/--without-PACKAGE but we can achieve the same result using the cached path variable. Since there are no static hooks into ebtables it doesn't get picked up via the automatic RDEPENDS so we also ensure that we add the RDEPENDS explicitly here. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_1.0.3.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.0.3.bb b/recipes-extended/libvirt/libvirt_1.0.3.bb
index fb4b9bb..0d1d081 100644
--- a/recipes-extended/libvirt/libvirt_1.0.3.bb
+++ b/recipes-extended/libvirt/libvirt_1.0.3.bb
@@ -3,10 +3,10 @@ HOMEPAGE = "http://libvirt.org"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=fb919cc88dbe06ec0b0bd50e001ccf1f"
SECTION = "console/tools"
-PR = "r8"
+PR = "r9"
DEPENDS = "bridge-utils gnutls libxml2 lvm2 avahi parted curl libpcap util-linux e2fsprogs pm-utils \
- iptables ebtables dnsmasq readline"
+ iptables dnsmasq readline"
# These might be included by PACKAGECONFIG
#RRECOMMENDS+= "polkit qemu yajl libnl lxc netcf"
@@ -113,7 +113,9 @@ INITSCRIPT_PARAMS_${PN}-libvirtd = "defaults 72"
# full config
PACKAGECONFIG ??= "qemu yajl xen libxl xen-inotify uml openvz vmware vbox esx \
- polkit lxc test remote macvtap libvirtd netcf udev python ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
+ polkit lxc test remote macvtap libvirtd netcf udev python \
+ ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
+ ebtables"
# enable,disable,depends,rdepends
#
@@ -140,6 +142,8 @@ PACKAGECONFIG[netcf] = "--with-netcf,--without-netcf,netcf,netcf"
PACKAGECONFIG[dtrace] = "--with-dtrace,--without-dtrace,,"
PACKAGECONFIG[udev] = "--with-udev --with-pciaccess,--without-udev,udev libpciaccess,"
PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux,"
+PACKAGECONFIG[ebtables] = "ac_cv_path_EBTABLES_PATH=/sbin/ebtables,ac_cv_path_EBTABLES_PATH=,ebtables,ebtables"
+
# Enable the Python tool support
require libvirt-python.inc