aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2013-06-28 13:26:02 -0400
committerBruce Ashfield <bruce.ashfield@windriver.com>2013-06-28 14:08:40 -0400
commita668e81713c0cf7c25b89beb9837fa83355b130c (patch)
tree1b50338011ebfe6ac54c62dc55b4f1dbb797eb0e
parent422934f846ec908adcf7ef4d191338c851372dc8 (diff)
libvirt: use 4 fields for PACKAGECONFIG[]
As per the PACKAGECONFIG documentation "You can omit any argument you like but must retain the separating commas". If we do not retain the separating commas, we might get parsing errors, or, worse, we will think we depend on many items that we do not enable. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-extended/libvirt/libvirt_1.0.3.bb38
1 files changed, 20 insertions, 18 deletions
diff --git a/recipes-extended/libvirt/libvirt_1.0.3.bb b/recipes-extended/libvirt/libvirt_1.0.3.bb
index 845baf5..fb4b9bb 100644
--- a/recipes-extended/libvirt/libvirt_1.0.3.bb
+++ b/recipes-extended/libvirt/libvirt_1.0.3.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://libvirt.org"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=fb919cc88dbe06ec0b0bd50e001ccf1f"
SECTION = "console/tools"
-PR = "r7"
+PR = "r8"
DEPENDS = "bridge-utils gnutls libxml2 lvm2 avahi parted curl libpcap util-linux e2fsprogs pm-utils \
iptables ebtables dnsmasq readline"
@@ -115,29 +115,31 @@ INITSCRIPT_PARAMS_${PN}-libvirtd = "defaults 72"
PACKAGECONFIG ??= "qemu yajl xen libxl xen-inotify uml openvz vmware vbox esx \
polkit lxc test remote macvtap libvirtd netcf udev python ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
-PACKAGECONFIG[qemu] = "--with-qemu,--without-qemu,qemu"
+# enable,disable,depends,rdepends
+#
+PACKAGECONFIG[qemu] = "--with-qemu,--without-qemu,qemu,"
PACKAGECONFIG[yajl] = "--with-yajl,--without-yajl,yajl,yajl"
-PACKAGECONFIG[xen] = "--with-xen,--without-xen,xen"
-PACKAGECONFIG[xenapi] = "--with-xenapi,--without-xenapi"
-PACKAGECONFIG[libxl] = "--with-libxl=${STAGING_DIR_TARGET}/lib,--without-libxl,xen"
-PACKAGECONFIG[xen-inotify] = "--with-xen-inotify,--without-xen-inotify,xen"
-PACKAGECONFIG[uml] = "--with-uml, --without-uml"
-PACKAGECONFIG[openvz] = "--with-openvz,--without-openvz"
-PACKAGECONFIG[vmware] = "--with-vmware,--without-vmware"
-PACKAGECONFIG[phyp] = "--with-phyp,--without-phyp"
-PACKAGECONFIG[vbox] = "--with-vbox,--without-vbox"
-PACKAGECONFIG[esx] = "--with-esx,--without-esx"
-PACKAGECONFIG[hyperv] = "--with-hyperv,--without-hyperv"
+PACKAGECONFIG[xen] = "--with-xen,--without-xen,xen,"
+PACKAGECONFIG[xenapi] = "--with-xenapi,--without-xenapi,,"
+PACKAGECONFIG[libxl] = "--with-libxl=${STAGING_DIR_TARGET}/lib,--without-libxl,xen,"
+PACKAGECONFIG[xen-inotify] = "--with-xen-inotify,--without-xen-inotify,xen,"
+PACKAGECONFIG[uml] = "--with-uml, --without-uml,,"
+PACKAGECONFIG[openvz] = "--with-openvz,--without-openvz,,"
+PACKAGECONFIG[vmware] = "--with-vmware,--without-vmware,,"
+PACKAGECONFIG[phyp] = "--with-phyp,--without-phyp,,"
+PACKAGECONFIG[vbox] = "--with-vbox,--without-vbox,,"
+PACKAGECONFIG[esx] = "--with-esx,--without-esx,,"
+PACKAGECONFIG[hyperv] = "--with-hyperv,--without-hyperv,,"
PACKAGECONFIG[polkit] = "--with-polkit,--without-polkit,polkit,polkit"
-PACKAGECONFIG[lxc] = "--with-lxc,--without-lxc, lxc"
-PACKAGECONFIG[test] = "--with-test=yes,--with-test=no"
-PACKAGECONFIG[remote] = "--with-remote,--without-remote"
+PACKAGECONFIG[lxc] = "--with-lxc,--without-lxc, lxc,"
+PACKAGECONFIG[test] = "--with-test=yes,--with-test=no,,"
+PACKAGECONFIG[remote] = "--with-remote,--without-remote,,"
PACKAGECONFIG[macvtap] = "--with-macvtap=yes,--with-macvtap=no,libnl,libnl"
-PACKAGECONFIG[libvirtd] = "--with-libvirtd,--without-libvirtd"
+PACKAGECONFIG[libvirtd] = "--with-libvirtd,--without-libvirtd,,"
PACKAGECONFIG[netcf] = "--with-netcf,--without-netcf,netcf,netcf"
PACKAGECONFIG[dtrace] = "--with-dtrace,--without-dtrace,,"
PACKAGECONFIG[udev] = "--with-udev --with-pciaccess,--without-udev,udev libpciaccess,"
-PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
+PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux,"
# Enable the Python tool support
require libvirt-python.inc