aboutsummaryrefslogtreecommitdiff
path: root/debian/extra/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'debian/extra/Makefile')
-rw-r--r--debian/extra/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/extra/Makefile b/debian/extra/Makefile
new file mode 100644
index 0000000..b34f7ac
--- /dev/null
+++ b/debian/extra/Makefile
@@ -0,0 +1,22 @@
+CFLAGS = -O2 -Wall -g
+CC = cc
+INSTALL = install -m755 -o root -g root
+INSTALLDIR = install -m755 -o root -g root -d
+DESTDIR =
+prefix = /usr/local
+bindir = $(prefix)/bin
+mandir = $(prefix)/share/man/man1
+
+all: jpegexiforient
+
+jpegexiforient: jpegexiforient.c
+ $(CC) $(CFLAGS) -o jpegexiforient jpegexiforient.c
+clean:
+ -rm -f jpegexiforient
+install:
+ $(INSTALLDIR) $(DESTDIR)$(bindir)
+ $(INSTALLDIR) $(DESTDIR)$(mandir)
+ $(INSTALL) jpegexiforient $(DESTDIR)$(bindir)
+ $(INSTALL) jpegexiforient.1 $(DESTDIR)$(mandir)
+ $(INSTALL) exifautotran $(DESTDIR)$(bindir)
+ $(INSTALL) exifautotran.1 $(DESTDIR)$(mandir)