aboutsummaryrefslogtreecommitdiff
path: root/debian/extra/Makefile
diff options
context:
space:
mode:
authorTom Gall <tom.gall@linaro.org>2011-12-23 10:42:23 -0600
committerTom Gall <tom.gall@linaro.org>2011-12-23 10:42:23 -0600
commitd519a0ef385e8d74fce083497630ffb4e9ba0adc (patch)
tree1b145eb57dd8a40f710ff23ec591703b24e3aa0c /debian/extra/Makefile
parentf1a90e77f305fc679c9fcbd4c5a11deb48f92c29 (diff)
sync to as released debian control files and such for the packageHEADmaster
Diffstat (limited to 'debian/extra/Makefile')
-rw-r--r--debian/extra/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/debian/extra/Makefile b/debian/extra/Makefile
new file mode 100644
index 0000000..b34f7ac
--- /dev/null
+++ b/debian/extra/Makefile
@@ -0,0 +1,22 @@
+CFLAGS = -O2 -Wall -g
+CC = cc
+INSTALL = install -m755 -o root -g root
+INSTALLDIR = install -m755 -o root -g root -d
+DESTDIR =
+prefix = /usr/local
+bindir = $(prefix)/bin
+mandir = $(prefix)/share/man/man1
+
+all: jpegexiforient
+
+jpegexiforient: jpegexiforient.c
+ $(CC) $(CFLAGS) -o jpegexiforient jpegexiforient.c
+clean:
+ -rm -f jpegexiforient
+install:
+ $(INSTALLDIR) $(DESTDIR)$(bindir)
+ $(INSTALLDIR) $(DESTDIR)$(mandir)
+ $(INSTALL) jpegexiforient $(DESTDIR)$(bindir)
+ $(INSTALL) jpegexiforient.1 $(DESTDIR)$(mandir)
+ $(INSTALL) exifautotran $(DESTDIR)$(bindir)
+ $(INSTALL) exifautotran.1 $(DESTDIR)$(mandir)