aboutsummaryrefslogtreecommitdiff
path: root/src/wheelencoder/CMakeLists.txt
diff options
context:
space:
mode:
authorJon Trulson <jtrulson@ics.com>2015-08-27 16:57:16 -0600
committersisinty sasmita patra <sisinty.s.patra@intel.com>2015-08-31 11:58:49 -0700
commitb0625e11f18d904fb14988b19fea4e5adc9d276a (patch)
tree0db61516d9e3fe9a223c2a8a8dcf554664934359 /src/wheelencoder/CMakeLists.txt
parent60cfe88e37fee366fc81b0b809bd6eff308a30e5 (diff)
wheelencoder: Initial implementation
This driver was developed for the DFRobot Wheel Encoder, though it could be used for any counting time-based task using a digital i/o pin to generate interrupts. http://www.dfrobot.com/index.php?route=product/product&product_id=98 If you want to use more than one encoder, simply create a class instance for each one. Signed-off-by: Jon Trulson <jtrulson@ics.com> Signed-off-by: sisinty sasmita patra <sisinty.s.patra@intel.com>
Diffstat (limited to 'src/wheelencoder/CMakeLists.txt')
-rw-r--r--src/wheelencoder/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/wheelencoder/CMakeLists.txt b/src/wheelencoder/CMakeLists.txt
new file mode 100644
index 0000000..9528920
--- /dev/null
+++ b/src/wheelencoder/CMakeLists.txt
@@ -0,0 +1,5 @@
+set (libname "wheelencoder")
+set (libdescription "upm DFRobot wheelencoder")
+set (module_src ${libname}.cxx)
+set (module_h ${libname}.h)
+upm_module_init()