aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorMike Holmes <mike.holmes@linaro.org>2017-01-20 15:32:02 -0500
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-01-22 21:54:53 +0300
commit19a457a86880a6bc33afe891a6204752bde70088 (patch)
treef13be2fe360f8ab895da809a893cc3578faab270 /helper/Makefile.am
parent7025b1b430237cddc10a0338c7b120d23b7985a8 (diff)
helper: move thread implementation under platform
Only the portable api is built by default, use --enable-helper-extn to enable non portable APIs for a helper platform Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-by: Christophe Milard <christophe.milard@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am16
1 files changed, 13 insertions, 3 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index 62e55cca6..9b2f18a70 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -1,7 +1,7 @@
include $(top_srcdir)/platform/@with_platform@/Makefile.inc
pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = $(top_builddir)/pkgconfig/libodphelper-linux.pc
+pkgconfig_DATA = $(top_builddir)/pkgconfig/libodphelper-linux-generic.pc
LIB = $(top_builddir)/lib
AM_CFLAGS = -I$(srcdir)/include
@@ -25,6 +25,11 @@ helperinclude_HEADERS = \
$(srcdir)/include/odp/helper/threads.h \
$(srcdir)/include/odp/helper/udp.h
+if helper_extn
+helperinclude_HEADERS += \
+ $(srcdir)/include/odp/helper/platform/@with_helper_platform@/threads_extn.h
+endif
+
noinst_HEADERS = \
$(srcdir)/odph_debug.h \
$(srcdir)/odph_hashtable.h \
@@ -33,7 +38,7 @@ noinst_HEADERS = \
$(srcdir)/odph_list_internal.h \
$(srcdir)/odph_iplookuptable.h
-__LIB__libodphelper_linux_la_SOURCES = \
+__LIB__libodphelper_@with_platform@_la_SOURCES = \
eth.c \
ip.c \
chksum.c \
@@ -43,4 +48,9 @@ __LIB__libodphelper_linux_la_SOURCES = \
iplookuptable.c \
threads.c
-lib_LTLIBRARIES = $(LIB)/libodphelper-linux.la
+if helper_extn
+__LIB__libodphelper_@with_platform@_la_SOURCES += \
+ platform/@with_helper_platform@/thread.c
+endif
+
+lib_LTLIBRARIES = $(LIB)/libodphelper-@with_platform@.la