aboutsummaryrefslogtreecommitdiff
path: root/helper/Makefile.am
diff options
context:
space:
mode:
authorMike Holmes <mike.holmes@linaro.org>2017-01-20 15:32:01 -0500
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-01-22 21:54:46 +0300
commit7025b1b430237cddc10a0338c7b120d23b7985a8 (patch)
tree224576667db8b53e914e9286f6e52a257ac155e4 /helper/Makefile.am
parent0f18e317ede15081828deca1ff61d65b72e12926 (diff)
helper: cleanup Linux rename to thread
Remove the OS specific Linux filename and use the name of the generic apis it contains which is for odp_threads Signed-off-by: Mike Holmes <mike.holmes@linaro.org> Reviewed-by: Christophe Milard <christophe.milard@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'helper/Makefile.am')
-rw-r--r--helper/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/helper/Makefile.am b/helper/Makefile.am
index 9d0036de0..62e55cca6 100644
--- a/helper/Makefile.am
+++ b/helper/Makefile.am
@@ -14,7 +14,6 @@ AM_LDFLAGS += -version-number '$(ODPHELPER_LIBSO_VERSION)'
helperincludedir = $(includedir)/odp/helper/
helperinclude_HEADERS = \
- $(srcdir)/include/odp/helper/linux.h \
$(srcdir)/include/odp/helper/chksum.h\
$(srcdir)/include/odp/helper/eth.h\
$(srcdir)/include/odp/helper/icmp.h\
@@ -23,6 +22,7 @@ helperinclude_HEADERS = \
$(srcdir)/include/odp/helper/strong_types.h\
$(srcdir)/include/odp/helper/tcp.h\
$(srcdir)/include/odp/helper/table.h\
+ $(srcdir)/include/odp/helper/threads.h \
$(srcdir)/include/odp/helper/udp.h
noinst_HEADERS = \
@@ -37,10 +37,10 @@ __LIB__libodphelper_linux_la_SOURCES = \
eth.c \
ip.c \
chksum.c \
- linux.c \
hashtable.c \
lineartable.c \
cuckootable.c \
- iplookuptable.c
+ iplookuptable.c \
+ threads.c
lib_LTLIBRARIES = $(LIB)/libodphelper-linux.la