aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJere Leppänen <jere.leppanen@nokia.com>2022-09-20 17:19:02 +0300
committerMatias Elo <matias.elo@nokia.com>2022-10-19 13:29:08 +0300
commite924ab56a026b584aab1c10f7e7210a77d51bb9f (patch)
tree02e6a7cd5f3868fe343cae05b2e54ee6f73e8db7 /configure.ac
parentb00b8c06310602cc34bdebf6f3eed978ea95864d (diff)
test: misc: in installcheck, work around bug in legacy pkgconfig
pkgconfig-0.27 returns linker option in the wrong order. Detect pkgconfig version and add the static libraries explicitly to the compiler command. Signed-off-by: Jere Leppänen <jere.leppanen@nokia.com> Reviewed-by: Tuomas Taipale <tuomas.taipale@nokia.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 70a90f58c..251789834 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,6 +90,16 @@ LT_INIT([])
AC_SUBST([LIBTOOL_DEPS])
AM_PROG_LIBTOOL
+##########################################################################
+# Detect legacy pkgconfig-0.27
+##########################################################################
+PKG_PROG_PKG_CONFIG([0.28])
+pkgconfig_workaround=yes
+AS_IF([test "x$PKG_CONFIG" != "x"],
+ [pkgconfig_workaround=no])
+AM_CONDITIONAL([PKGCONFIG_WORKAROUND],
+ [test "x$pkgconfig_workaround" = "xyes"])
+
PKG_PROG_PKG_CONFIG
##########################################################################