aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJere Leppänen <jere.leppanen@nokia.com>2022-09-20 17:01:30 +0300
committerMatias Elo <matias.elo@nokia.com>2022-10-19 13:29:08 +0300
commitb00b8c06310602cc34bdebf6f3eed978ea95864d (patch)
treeccc29419930cb70d6e6e847709841116e636c06c /configure.ac
parentb0aac4a0fcb21a7ddaa7a3540857878df6197ecb (diff)
test: misc: build and run a test application during installcheck
During installcheck, build and run a test application (odp_api_headers), to verify the install. When cross compiling, the application is built, but not run. Signed-off-by: Jere Leppänen <jere.leppanen@nokia.com> Reviewed-by: Tuomas Taipale <tuomas.taipale@nokia.com> Reviewed-by: Matias Elo <matias.elo@nokia.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d184c7fbc..70a90f58c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -427,6 +427,11 @@ AC_SUBST([ODP_LDFLAGS])
AC_SUBST([EXEEXT])
+AM_CONDITIONAL([enable_static], [test x$enable_static = xyes ])
+AM_CONDITIONAL([enable_shared], [test x$enable_shared = xyes ])
+
+AM_CONDITIONAL([cross_compile], [test x$host != x -a x$host != x$build ])
+
CC_VERSION=$($CC --version | head -n 1)
AC_OUTPUT
@@ -439,6 +444,7 @@ AC_MSG_RESULT([
Helper version: ${ODPH_VERSION}
implementation_name: ${ODP_IMPLEMENTATION_NAME}
+ build: ${build}
host: ${host}
ARCH_DIR ${ARCH_DIR}
ARCH_ABI ${ARCH_ABI}
@@ -450,7 +456,6 @@ AC_MSG_RESULT([
libdir: ${libdir}
includedir: ${includedir}
testdir: ${testdir}
- WITH_ARCH: ${WITH_ARCH}
cc: ${CC}
cc version: ${CC_VERSION}