aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>2017-10-05 04:14:54 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-10-16 21:50:18 +0300
commitcc33578e327d5f6787711a71a60500c4be98bf63 (patch)
treea691c6a523068ecb069b5bfdb1ccabaa093d8563 /configure.ac
parent4ab7a7b22b15011eb69c3e473278db13319aba52 (diff)
include: include all ABI files into distribution
Due to the way Automake interacts with autoconf substitutions, ODP tarballs included ABI headers only for the current directory. Include all ABI headers into tarball. Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org> Reviewed-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f68ff7e6e..80bc3122a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -224,6 +224,8 @@ AM_CONDITIONAL([ARCH_IS_AARCH64], [test "x${ARCH_DIR}" = "xaarch64"])
AM_CONDITIONAL([ARCH_IS_MIPS64], [test "x${ARCH_DIR}" = "xmips64"])
AM_CONDITIONAL([ARCH_IS_POWERPC], [test "x${ARCH_DIR}" = "xpowerpc"])
AM_CONDITIONAL([ARCH_IS_X86], [test "x${ARCH_DIR}" = "xx86"])
+AM_CONDITIONAL([ARCH_IS_X86_32], [test "x${ARCH_ABI}" = "xx86_32-linux"])
+AM_CONDITIONAL([ARCH_IS_X86_64], [test "x${ARCH_ABI}" = "xx86_64-linux"])
##########################################################################
# Setup doxygen documentation