aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>2017-10-05 03:53:30 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-10-16 21:50:18 +0300
commit4ab7a7b22b15011eb69c3e473278db13319aba52 (patch)
tree85ef92e8bc91f74316fbbc7d79b6808d40b265d8 /configure.ac
parent53b735f14a9a1df23b054f15ce148e2fa36abe0f (diff)
build: move handling of include files to include dir
There is little point in handling common headers in platform-specific dir. Move respective definitions to include/Makefie.am. Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org> Reviewed-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 345212cf4..f68ff7e6e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,9 +16,6 @@ ODP_VERSION_API_MAJOR=odpapi_major_version
AC_SUBST(ODP_VERSION_API_MAJOR)
ODP_VERSION_API_MINOR=odpapi_minor_version
AC_SUBST(ODP_VERSION_API_MINOR)
-AC_CONFIG_FILES([include/odp/api/spec/version.h
- include/odp/api/spec/deprecated.h])
-
AM_INIT_AUTOMAKE([1.9 tar-pax subdir-objects foreign nostdinc])
AC_CONFIG_SRCDIR([include/odp/api/spec/init.h])
AM_CONFIG_HEADER([include/config.h])
@@ -358,6 +355,10 @@ CFLAGS="$CFLAGS $ODP_CFLAGS"
CXXFLAGS="$CXXFLAGS $ODP_CXXFLAGS"
AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([include/Makefile
+ include/odp/api/spec/version.h
+ include/odp/api/spec/deprecated.h])
+
##########################################################################
# distribute the changed variables among the Makefiles