aboutsummaryrefslogtreecommitdiff
path: root/debian/rules.d
diff options
context:
space:
mode:
authorTim Gardner <tim.gardner@canonical.com>2011-09-14 10:14:17 -0600
committerLinaro CI <john.rigby@linaro.org>2012-02-07 22:50:15 +0000
commit6544e016c9d727ce1c5507c8d4fd674df50aa6df (patch)
treece3dc5818232490dcd2c92c4b58b0772f4c614c5 /debian/rules.d
parent82b9756ee7d93e51b51c684e639e070205d7c351 (diff)
UBUNTU: [Config] Fix binary-% build target
Simplify the checks-% target such that ABI and modules checks are built in parallel whilst both depend on the build stamp. Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
Diffstat (limited to 'debian/rules.d')
-rw-r--r--debian/rules.d/4-checks.mk16
1 files changed, 6 insertions, 10 deletions
diff --git a/debian/rules.d/4-checks.mk b/debian/rules.d/4-checks.mk
index cc953b7b7b4..c4df2fabaed 100644
--- a/debian/rules.d/4-checks.mk
+++ b/debian/rules.d/4-checks.mk
@@ -1,25 +1,21 @@
# Check ABI for package against last release (if not same abinum)
-$(abidir)/%: $(stampdir)/stamp-build-%
+abi-check-%: $(stampdir)/stamp-build-%
install -d $(abidir)
sed -e 's/^\(.\+\)[[:space:]]\+\(.\+\)[[:space:]]\(.\+\)$$/\3 \2 \1/' \
- $(builddir)/build-$*/Module.symvers | sort > $@
-
-abi-check-%: $(abidir)/%
+ $(builddir)/build-$*/Module.symvers | sort > $(abidir)/$*
@perl -f $(DROOT)/scripts/abi-check "$*" "$(prev_abinum)" "$(abinum)" \
"$(prev_abidir)" "$(abidir)" "$(skipabi)"
# Check the module list against the last release (always)
-$(abidir)/%.modules: abi-check-%
+module-check-%: $(stampdir)/stamp-build-%
install -d $(abidir)
find $(builddir)/build-$*/ -name \*.ko | \
- sed -e 's/.*\/\([^\/]*\)\.ko/\1/' | sort > $@
-
-module-check-%: $(abidir)/%.modules
+ sed -e 's/.*\/\([^\/]*\)\.ko/\1/' | sort > $(abidir)/$*.modules
@perl -f $(DROOT)/scripts/module-check "$*" \
"$(prev_abidir)" "$(abidir)" $(skipmodule)
-checks-%: module-check-%
- @# Will be calling more stuff later
+checks-%: module-check-% abi-check-%
+ @echo checks-$*
# Check the config against the known options list.
config-prepare-check-%: $(stampdir)/stamp-prepare-tree-%