summaryrefslogtreecommitdiff
path: root/smartt-top/debian/patches/makefile_dev_null.patch
diff options
context:
space:
mode:
Diffstat (limited to 'smartt-top/debian/patches/makefile_dev_null.patch')
-rw-r--r--smartt-top/debian/patches/makefile_dev_null.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/smartt-top/debian/patches/makefile_dev_null.patch b/smartt-top/debian/patches/makefile_dev_null.patch
new file mode 100644
index 0000000..8790156
--- /dev/null
+++ b/smartt-top/debian/patches/makefile_dev_null.patch
@@ -0,0 +1,13 @@
+Author: <xaiki@gonzo>
+Description: Make sure Makefile doesnt zot random files while checking GCC
+--- a/Makefile
++++ b/Makefile
+@@ -120,7 +120,7 @@
+ # Unlike the kernel one, this check_gcc goes all the way to
+ # producing an executable. There might be a -m64 that works
+ # until you go looking for a 64-bit curses library.
+-check_gcc = $(shell if $(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) dummy.c $(ALL_LDFLAGS) $(1) -o /dev/null $(CURSES) $(CURSESW) > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi ;)
++check_gcc = $(shell if $(CC) $(ALL_CPPFLAGS) $(ALL_CFLAGS) dummy.c $(ALL_LDFLAGS) $(1) -o will_this_file_really_exist.tmp $(CURSES) $(CURSESW) > /dev/null 2>&1; then echo "$(1)"; else echo "$(2)"; fi ; rm -f will_this_file_really_exist.tmp)
+
+ # Be 64-bit if at all possible. In a cross-compiling situation, one may
+ # do "make m64=-m32 lib64=lib" to produce 32-bit executables. DO NOT