aboutsummaryrefslogtreecommitdiff
path: root/runtime/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHans Wennborg <hans@hanshq.net>2016-06-27 18:03:45 +0000
committerHans Wennborg <hans@hanshq.net>2016-06-27 18:03:45 +0000
commitad958989b044b881aaeca6e3dcb88e938d5ef750 (patch)
treeec82e24dfc0d481b11ac42b9dc155ef16c0b323e /runtime/src/CMakeLists.txt
parent153bf3fb970bae9e15811f731c4bc45d53a7edf6 (diff)
Fix the Windows build after r273599
That patch made all LLVM projects build with -DUNICODE. However, this doesn't work for the OpenMP runtime. But just overriding the flag with -UUNICODE breaks compiling ittnotify_static.c, which for some reason needs to be compiled with -DUNICIODE. Note that compiling ittnotify.h with -DUNICODE does not work though. This seems like a mess. This commit fixes it for now, but it would be great if someone who works on the OpenMP runtime could fix it properly. git-svn-id: https://llvm.org/svn/llvm-project/openmp/trunk@273898 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'runtime/src/CMakeLists.txt')
-rw-r--r--runtime/src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/runtime/src/CMakeLists.txt b/runtime/src/CMakeLists.txt
index 9f8d2b0..57d7c2f 100644
--- a/runtime/src/CMakeLists.txt
+++ b/runtime/src/CMakeLists.txt
@@ -192,7 +192,7 @@ if(WIN32)
libomp_append(LIBOMP_MASM_DEFINITIONS "-DOMPT_SUPPORT" IF_TRUE_1_0 LIBOMP_OMPT_SUPPORT)
libomp_list_to_string("${LIBOMP_MASM_DEFINITIONS}" LIBOMP_MASM_DEFINITIONS)
set_property(SOURCE z_Windows_NT-586_asm.asm APPEND_STRING PROPERTY COMPILE_FLAGS " ${LIBOMP_MASM_DEFINITIONS}")
- set_source_files_properties(thirdparty/ittnotify/ittnotify_static.c PROPERTIES COMPILE_DEFINITIONS "UNICODE")
+ #set_source_files_properties(thirdparty/ittnotify/ittnotify_static.c PROPERTIES COMPILE_DEFINITIONS "UNICODE")
# Create Windows import library
# the import library is "re-linked" to include kmp_import.c which prevents