aboutsummaryrefslogtreecommitdiff
path: root/libomptarget/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJonas Hahnfeld <hahnjo@hahnjo.de>2017-12-06 21:59:12 +0000
committerJonas Hahnfeld <hahnjo@hahnjo.de>2017-12-06 21:59:12 +0000
commit25af465ca4ae2658fe527e9e68612e4ab9eb1141 (patch)
tree2f86871e0d6eddad1ca0d0508870f68b78cb9a07 /libomptarget/src/CMakeLists.txt
parent4303e181d4ad336605a76146e4291c9d2f154b95 (diff)
[libomptarget] Split implementation of API functions
This third patch moves the implementation of the user-facing OpenMP API functions into its own file. For now, the code is only moved, no cleanups applied yet. Differential Revision: https://reviews.llvm.org/D40800 git-svn-id: https://llvm.org/svn/llvm-project/openmp/trunk@319971 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'libomptarget/src/CMakeLists.txt')
-rw-r--r--libomptarget/src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/libomptarget/src/CMakeLists.txt b/libomptarget/src/CMakeLists.txt
index 8382432..220234a 100644
--- a/libomptarget/src/CMakeLists.txt
+++ b/libomptarget/src/CMakeLists.txt
@@ -14,6 +14,7 @@
libomptarget_say("Building offloading runtime library libomptarget.")
set(src_files
+ api.cpp
device.cpp
rtl.cpp
omptarget.cpp