aboutsummaryrefslogtreecommitdiff
path: root/pp-trace/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Thompson <John.Thompson.JTSoftware@gmail.com>2013-10-31 12:23:32 +0000
committerJohn Thompson <John.Thompson.JTSoftware@gmail.com>2013-10-31 12:23:32 +0000
commit37f6cf49eaeee3512678d1c6816087591823dadd (patch)
tree873c2a6610263b9199bee40782f6a3922029231a /pp-trace/CMakeLists.txt
parent5adcc11e99ada0726e813b5aa1e9a7b218c33cd9 (diff)
pp-trace - preprocessor tacing and PPCallbacks testing tool
git-svn-id: https://llvm.org/svn/llvm-project/clang-tools-extra/trunk@193743 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'pp-trace/CMakeLists.txt')
-rw-r--r--pp-trace/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/pp-trace/CMakeLists.txt b/pp-trace/CMakeLists.txt
new file mode 100644
index 00000000..6fc4baf6
--- /dev/null
+++ b/pp-trace/CMakeLists.txt
@@ -0,0 +1,18 @@
+set(LLVM_LINK_COMPONENTS
+ ${LLVM_TARGETS_TO_BUILD}
+ asmparser
+ support
+ mc
+ )
+
+add_clang_executable(pp-trace
+ PPTrace.cpp
+ PPCallbacksTracker.cpp
+ )
+
+target_link_libraries(pp-trace
+ clangLex
+ clangParse
+ clangSema
+ clangTooling
+ )