aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Ballman <aaron@aaronballman.com>2018-09-30 17:22:58 +0000
committerAaron Ballman <aaron@aaronballman.com>2018-09-30 17:22:58 +0000
commit1f9ec52e0d16cd6b3d72f7c16dd8c81d4d726c4c (patch)
treed5dd41507e4ea1f1c3d1ed149695391c0c4edf15 /CMakeLists.txt
parent3e4193d671157ed4543e9c172ad4d8b6375c392a (diff)
Allow clang-tidy to be built without a dependency on the clang static analyzer.
Patch by Stephen Kelly. git-svn-id: https://llvm.org/svn/llvm-project/clang-tools-extra/trunk@343415 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c434682c..c3137ade 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,10 +1,8 @@
add_subdirectory(clang-apply-replacements)
add_subdirectory(clang-reorder-fields)
add_subdirectory(modularize)
-if(CLANG_ENABLE_STATIC_ANALYZER)
add_subdirectory(clang-tidy)
add_subdirectory(clang-tidy-vs)
-endif()
add_subdirectory(change-namespace)
add_subdirectory(clang-doc)