aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 12b9c550726..9a23049a6ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1535,7 +1535,10 @@ fi
dnl Provide configure switches and initialize clooginc & clooglibs
dnl with user input.
CLOOG_INIT_FLAGS
-if test "x$with_cloog" != "xno"; then
+if test "x$isllibs" = x && test "x$islinc" = x; then
+ clooglibs=
+ clooginc=
+elif test "x$with_cloog" != "xno"; then
dnl The minimal version of CLooG required for Graphite.
dnl
dnl If we use CLooG-Legacy, the provided version information is
@@ -1547,6 +1550,12 @@ if test "x$with_cloog" != "xno"; then
AC_MSG_ERROR([Unable to find a usable CLooG. See config.log for details.])])
fi
+# If either the ISL or the CLooG check failed, disable builds of in-tree
+# variants of both
+if test "x$clooglibs" = x && test "x$clooginc" = x; then
+ noconfigdirs="$noconfigdirs cloog isl"
+fi
+
# Check for LTO support.
AC_ARG_ENABLE(lto,
[AS_HELP_STRING([--enable-lto], [enable link time optimization support])],