aboutsummaryrefslogtreecommitdiff
path: root/libgo/configure.ac
diff options
context:
space:
mode:
authorian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2014-11-14 18:02:50 +0000
committerian <ian@138bc75d-0d04-0410-961f-82ee72b054a4>2014-11-14 18:02:50 +0000
commitb5f8bff07ee42a1c2d93fd6484b34e2e38ff04aa (patch)
treeab0b06d6b17b3adc80d4bfbfe17e29a01492b1df /libgo/configure.ac
parent04c849b31c5935979173f0b33f6a92506324ddd5 (diff)
runtime: set library name based on compiler name
Different compilers may have different release cadences or ABI incompatibilities, so it does not make sense to use the same library name for runtime libraries intended for different compilers. This CL causes a libgo built by llgo to receive the name libgo-llgo. Likewise, libgobegin is named libgobegin-llgo. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@217583 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libgo/configure.ac')
-rw-r--r--libgo/configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/libgo/configure.ac b/libgo/configure.ac
index d651827fee5..6dac4d693fe 100644
--- a/libgo/configure.ac
+++ b/libgo/configure.ac
@@ -392,6 +392,14 @@ if test "$libgo_cv_c_linker_supports_split_stack" = yes; then
[Define if the linker support split stack adjustments])
fi
+AC_CACHE_CHECK([whether compiler is llgo],
+[libgo_cv_c_goc_is_llgo],
+[libgo_cv_c_goc_is_llgo=no
+if $GOC -dumpversion 2>/dev/null | grep llgo >/dev/null 2>&1; then
+ libgo_cv_c_goc_is_llgo=yes
+fi])
+AM_CONDITIONAL(GOC_IS_LLGO, test "$libgo_cv_c_goc_is_llgo" = yes)
+
dnl Test for the -lm library.
MATH_LIBS=
AC_CHECK_LIB([m], [sqrt], MATH_LIBS=-lm)