aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorwehle <wehle@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-23 19:41:03 +0000
committerwehle <wehle@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-23 19:41:03 +0000
commitd6723bcdea35b4af295adf7b32907324878fa75c (patch)
tree9c863568a597265314722ecb9fada3fd21ed7fb8 /gcc/configure.in
parent9c4fbff9f97953a50ec55067de822e3ad27e7f1c (diff)
* acconfig.h (HAVE_GAS_FILDS_FISTS): Add.
* configure.in: Check assembler instructions. * configure: Rebuild. * config.in: Likewise. * i386.md (floathisf2, floathidf2, floathixf2): New patterns. * i386.c (print_operand): Use the proper suffix for a 387 HImode operand. Abort if a 387 operand has an unsupported size. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@26608 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in17
1 files changed, 17 insertions, 0 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 9f8c9681e81..e343d27860f 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -3975,6 +3975,23 @@ EOF
fi
AC_MSG_RESULT($gcc_cv_as_subsections)
+AC_MSG_CHECKING(assembler instructions)
+gcc_cv_as_instructions=
+if test x$gcc_cv_as != x; then
+ set "filds fists" "filds mem; fists mem"
+ while test $# -gt 0
+ do
+ echo "$2" > conftest.s
+ if $gcc_cv_as -o conftest.o conftest.s > /dev/null 2>&1; then
+ gcc_cv_as_instructions=${gcc_cv_as_instructions}$1" "
+ AC_DEFINE_UNQUOTED(HAVE_GAS_`echo "$1" | tr '[a-z ]' '[A-Z_]'`)
+ fi
+ shift 2
+ done
+ rm -f conftest.s conftest.o
+fi
+AC_MSG_RESULT($gcc_cv_as_instructions)
+
# Figure out what language subdirectories are present.
# Look if the user specified --enable-languages="..."; if not, use
# the environment variable $LANGUAGES if defined. $LANGUAGES might