aboutsummaryrefslogtreecommitdiff
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-02 14:56:49 +0000
committerlaw <law@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-02 14:56:49 +0000
commitb441f25a73400eee63440af74625b53827dc42bd (patch)
treee54143aae94e849f4f415677715c8274f2f06ce4 /gcc/configure.in
parent0413846db302fb1def03bc53f84ca370eba8cd86 (diff)
* configure.in: Set and substitute quoted_cc_set_by_configure.
* configure: Rebuilt. * Makefile.in (SUBDIR_FLAGS_TO_PASS): Fix quoting problem with ``. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@26129 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index c132e2562f1..f8ad60fe660 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -3706,6 +3706,7 @@ rm -f symtest.tem
if $symbolic_link $srcdir/gcc.c symtest.tem 2>/dev/null
then
cc_set_by_configure="\$(CC)"
+ quoted_cc_set_by_configure="\$(CC)"
stage_prefix_set_by_configure="\$(STAGE_PREFIX)"
else
rm -f symtest.tem
@@ -3716,6 +3717,7 @@ else
symbolic_link="cp"
fi
cc_set_by_configure="\`case '\$(CC)' in stage*) echo '\$(CC)' | sed -e 's|stage|../stage|g';; *) echo '\$(CC)';; esac\`"
+ quoted_cc_set_by_configure="\\\`case '\\\$(CC)' in stage*) echo '\\\$(CC)' | sed -e 's|stage|../stage|g';; *) echo '\\\$(CC)';; esac\\\`"
stage_prefix_set_by_configure="\`case '\$(STAGE_PREFIX)' in stage*) echo '\$(STAGE_PREFIX)' | sed -e 's|stage|../stage|g';; *) echo '\$(STAGE_PREFIX)';; esac\`"
fi
rm -f symtest.tem
@@ -4225,6 +4227,7 @@ AC_SUBST(build_exeext)
AC_SUBST(build_install_headers_dir)
AC_SUBST(build_xm_file_list)
AC_SUBST(cc_set_by_configure)
+AC_SUBST(quoted_cc_set_by_configure)
AC_SUBST(cpp_install_dir)
AC_SUBST(cpp_main)
AC_SUBST(dep_host_xmake_file)