aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorH.J. Lu <hongjiu.lu@intel.com>2004-11-04 17:05:21 +0000
committerH.J. Lu <hjl@gcc.gnu.org>2004-11-04 09:05:21 -0800
commit420ebfefc129fb2d5a6eb99b62e0e16ccff23728 (patch)
tree231ee7434dc456a0b99a9b5fc99b55c051e47ffc /configure.in
parent5fa08fdc492df3f59b9bb93b535912088753d99e (diff)
re PR other/17783 (Top level configure doesn't support shared libraries enabled by default)
2004-11-04 H.J. Lu <hongjiu.lu@intel.com> PR other/17783 * configure.in: Set up LD_LIBRARY_PATH by default for gcc. * configure: Regenerated. From-SVN: r90069
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 19 insertions, 4 deletions
diff --git a/configure.in b/configure.in
index 7b819f0b615..3040762f5f7 100644
--- a/configure.in
+++ b/configure.in
@@ -1612,10 +1612,25 @@ case "${host}" in
;;
esac
+# If no --enable-shared nor --disable-shared is specified, we set up
+# LD_LIBRARY_PATH when we build for gcc.
+case $enable_shared in
+"")
+ if test -d ${srcdir}/gcc; then
+ set_lib_path=yes
+ else
+ set_lib_path=no
+ fi
+ ;;
+*)
+ set_lib_path=$enable_shared
+ ;;
+esac
+
# If --enable-shared was set, we must set LD_LIBRARY_PATH so that the
# binutils tools will find libbfd.so.
-case "${enable_shared}" in
- no | "") SET_LIB_PATH= ;;
+case "${set_lib_path}" in
+ no) SET_LIB_PATH= ;;
*) SET_LIB_PATH="\$(REALLY_SET_LIB_PATH)" ;;
esac
@@ -2150,8 +2165,8 @@ AC_SUBST(MAINT)dnl
# used.
SET_GCC_LIB_PATH=
if test -d ${srcdir}/gcc && test x${is_cross_compiler} = xno; then
- case "${enable_shared}" in
- no | "") ;;
+ case "${set_lib_path}" in
+ no) ;;
*)
eval "d=\$$RPATH_ENVVAR"
if test x"$d" != x; then