summaryrefslogtreecommitdiff
path: root/libc/ports/ChangeLog.mips
diff options
context:
space:
mode:
authorjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2013-10-18 21:33:25 +0000
committerjoseph <joseph@7b3dc134-2b1b-0410-93df-9e9f96275f8d>2013-10-18 21:33:25 +0000
commitfe2ed5aaa408e1ab996a9fe1595a05634208a79c (patch)
treee1027fbc9d8a4a8c33f8149b2b42e8cde89c74f6 /libc/ports/ChangeLog.mips
parent571c782b982d888565e7d06bfc2f3d47582fe829 (diff)
Merge changes between r23946 and r24305 from /fsf/trunk.
git-svn-id: svn://svn.eglibc.org/trunk@24306 7b3dc134-2b1b-0410-93df-9e9f96275f8d
Diffstat (limited to 'libc/ports/ChangeLog.mips')
-rw-r--r--libc/ports/ChangeLog.mips124
1 files changed, 124 insertions, 0 deletions
diff --git a/libc/ports/ChangeLog.mips b/libc/ports/ChangeLog.mips
index 5844bf589..eaa6ade59 100644
--- a/libc/ports/ChangeLog.mips
+++ b/libc/ports/ChangeLog.mips
@@ -1,3 +1,127 @@
+2013-09-26 Steve Ellcey <sellcey@mips.com>
+
+ [BZ #15632]
+ * sysdeps/mips/mips32/fpu/e_sqrt.c: New.
+ * sysdeps/mips/mips32/fpu/e_sqrtf.c: New.
+ * sysdeps/mips/mips64/n32/fpu/e_sqrt.c: New.
+ * sysdeps/mips/mips64/n32/fpu/e_sqrtf.c: New.
+ * sysdeps/mips/mips64/n64/fpu/e_sqrt.c: New.
+ * sysdeps/mips/mips64/n64/fpu/e_sqrtf.c: New.
+
+2013-09-23 Steve Ellcey <sellcey@mips.com>
+
+ * sysdeps/mips/math_private.h (libc_feholdexcept_mips): New function.
+ (libc_feholdexcept): New macro.
+ (libc_feholdexceptf): New macro.
+ (libc_feholdexceptl): New macro.
+ (libc_fesetround_mips): New function.
+ (libc_fesetround): New macro.
+ (libc_fesetroundf): New macro.
+ (libc_fesetroundl): New macro.
+ (libc_feholdexcept_setround_mips): New function.
+ (libc_feholdexcept_setround): New macro.
+ (libc_feholdexcept_setroundf): New macro.
+ (libc_feholdexcept_setroundl): New macro.
+ (libc_fesetenv_mips): New function.
+ (libc_fesetenv): New macro.
+ (libc_fesetenvf): New macro.
+ (libc_fesetenvl): New macro.
+ (libc_feupdateenv_mips): New function.
+ (libc_feupdateenv): New macro.
+ (libc_feupdateenvf): New macro.
+ (libc_feupdateenvl): New macro.
+
+2013-09-23 Maciej W. Rozycki <macro@codesourcery.com>
+
+ * sysdeps/mips/bits/atomic.h: Fix comment typo.
+
+2013-09-23 Steve Ellcey <sellcey@mips.com>
+
+ * sysdeps/mips/fpu/fegetround.c (fegetround): Use _FPU_RC_MASK.
+ * sysdeps/mips/fpu/fesetround.c (fesetround): Use _FPU_RC_MASK.
+
+2013-09-23 Steve Ellcey <sellcey@mips.com>
+
+ * sysdeps/mips/fpu_control.h (_FPU_RC_MASK): New.
+
+2013-09-23 Steve Ellcey <sellcey@mips.com>
+
+ * sysdeps/mips/fpu_control.h (comments): Add capitalization and
+ periods to match GNU standard.
+
+2013-09-20 Steve Ellcey <sellcey@mips.com>
+
+ * sysdeps/mips/memset.S: Change prefetching and add loop unrolling.
+ * sysdeps/mips/mips64/memset.S: Remove.
+
+2013-09-18 Maciej W. Rozycki <macro@codesourcery.com>
+ Thomas Schwinge <thomas@codesourcery.com>
+
+ * sysdeps/mips/dl-machine.h (ELF_MACHINE_NAN2008): New macro.
+ (elf_machine_matches_host): Reject objects that use a different
+ NaN encoding convention.
+ * sysdeps/mips/fpu_control.h: Document IEEE 754-2008 feature
+ control bits.
+ (_FPU_ABS2008, _FPU_NAN2008): New macros.
+ (_FPU_RESERVED): Clear bits #20 and #19.
+ (_FPU_DEFAULT) [__mips_nan2008]: Set bit #18.
+ (_FPU_IEEE) [__mips_nan2008]: Likewise.
+ * sysdeps/mips/math_private.h [__mips_nan2008]
+ (HIGH_ORDER_BIT_IS_SET_FOR_SNAN): Don't define.
+ * sysdeps/mips/bits/nan.h [__mips_nan2008] (__qnan_bytes): Define
+ appropriately.
+ * sysdeps/mips/mips64/soft-fp/sfp-machine.h [__mips_nan2008]
+ (_FP_NANFRAC_S, _FP_NANFRAC_D, _FP_NANFRAC_Q): Define 2008-NaN
+ payloads.
+ (_FP_QNANNEGATEDP): Set to 0.
+ * sysdeps/mips/soft-fp/sfp-machine.h [__mips_nan2008]
+ (_FP_NANFRAC_S, _FP_NANFRAC_D, _FP_NANFRAC_Q): Define 2008-NaN
+ payloads.
+ (_FP_QNANNEGATEDP): Set to 0.
+ * sysdeps/unix/sysv/linux/mips/dl-cache.h (_DL_CACHE_DEFAULT_ID):
+ Define 2008 NaN encoding values.
+ * sysdeps/unix/sysv/linux/mips/readelflib.c (process_elf_file):
+ Handle 2008-NaN libraries.
+ * sysdeps/mips/shlib-versions [HAVE_MIPS_NAN2008]: Set
+ ld=ld-linux-mipsn8.so.1.
+ * sysdeps/mips/configure.in: Define HAVE_MIPS_NAN2008 if the
+ 2008 NaN encoding is used.
+ * sysdeps/unix/sysv/linux/mips/Makefile (abi-variants): Add
+ 2008-NaN ABI variants.
+ (abi-o32_soft-options, abi-o32_soft-condition): Update with the
+ __mips_nan2008 macro.
+ (abi-o32_hard-options, abi-o32_hard-condition): Likewise.
+ (abi-n32_soft-options, abi-n32_soft-condition): Likewise.
+ (abi-n32_hard-options, abi-n32_hard-condition): Likewise.
+ (abi-n64_soft-options, abi-n64_soft-condition): Likewise.
+ (abi-n64_hard-options, abi-n64_hard-condition): Likewise.
+ (abi-o32_soft-ld-soname, abi-o32_hard-ld-soname): New macros.
+ (abi-n32_soft-ld-soname, abi-n32_hard-ld-soname): Likewise.
+ (abi-n64_soft-ld-soname, abi-n64_hard-ld-soname): Likewise.
+ (abi-o32_soft_2008-options): Likewise.
+ (abi-o32_soft_2008-condition): Likewise.
+ (abi-o32_hard_2008-options): Likewise.
+ (abi-o32_hard_2008-condition): Likewise.
+ (abi-n32_soft_2008-options): Likewise.
+ (abi-n32_soft_2008-condition): Likewise.
+ (abi-n32_hard_2008-options): Likewise.
+ (abi-n32_hard_2008-condition): Likewise.
+ (abi-n64_soft_2008-options): Likewise.
+ (abi-n64_soft_2008-condition): Likewise.
+ (abi-n64_hard_2008-options): Likewise.
+ (abi-n64_hard_2008-condition): Likewise.
+ (abi-o32_soft_2008-ld-soname): Likewise.
+ (abi-o32_hard_2008-ld-soname): Likewise.
+ (abi-n32_soft_2008-ld-soname): Likewise.
+ (abi-n32_hard_2008-ld-soname): Likewise.
+ (abi-n64_soft_2008-ld-soname): Likewise.
+ (abi-n64_hard_2008-ld-soname): Likewise.
+ * sysdeps/unix/sysv/linux/mips/configure.in: Include the NaN
+ encoding selection in default-abi. Set arch_minimum_kernel to
+ 10.0.0 if 2008 NaN encoding is used.
+ * sysdeps/mips/configure: Regenerate.
+ * sysdeps/unix/sysv/linux/mips/configure: Regenerate.
+
2013-08-30 Ondřej Bílka <neleai@seznam.cz>
* sysdeps/mips/memcpy.S: Fix then/than typos.