aboutsummaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
index 2815347..babcc41 100644
--- a/doc/Makefile.am
+++ b/doc/Makefile.am
@@ -29,8 +29,7 @@ docs: $(TARGETS)
%.rtf: %.sgml
src=$(srcdir); \
dir=`(cd $${src}; pwd)`; \
- touch $@; \
- $(DOCBOOK)/db2rtf -o $@ $${dir}/$*.sgml
+ $(DOCBOOK)/db2rtf $${dir}/$*.sgml
%.gif: %.fig
convert -transparency white $< $@ # .fig -> .gif
@@ -46,7 +45,8 @@ docs: $(TARGETS)
%.html: %.sgml
src=$(srcdir); \
dir=`(cd $${src}; pwd)`; \
- $(DOCBOOK)/db2html $${dir}/$*.sgml
+ mkdir html; \
+ $(DOCBOOK)/db2html -o html $${dir}/$*.sgml
# now for some extra dependencies that the automatic rules will not
# catch: