aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 0000000..263f043
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,24 @@
+dnl Process this file with autoconf to produce a configure script.
+AC_PREREQ(2.13)
+AC_INIT(runtest.exp)
+AC_CONFIG_AUX_DIR(..)
+
+dnl These are required by automake
+AM_INIT_AUTOMAKE(dejagnu, 20000518)
+AM_MAINTAINER_MODE
+AC_PROG_MAKE_SET
+AC_EXEEXT
+
+AC_PROG_CC
+AC_PROG_INSTALL
+
+dnl Level of indirection for automake macro (baseboards:boards_DATA)
+BOARDS='$(boards)'
+AC_SUBST(BOARDS)
+CONFIG='$(config)'
+AC_SUBST(CONFIG)
+
+AC_CONFIG_SUBDIRS(example/calc)
+
+AC_OUTPUT(Makefile doc/Makefile example/Makefile testsuite/Makefile)
+