aboutsummaryrefslogtreecommitdiff
path: root/testsuite/Makefile.am
diff options
context:
space:
mode:
authorRob Savoye <rob@welcomehome.org>2001-05-09 18:19:43 +0000
committerRob Savoye <rob@welcomehome.org>2001-05-09 18:19:43 +0000
commit63f46a0d3ea48d88ecca1be0102043df7a2403cb (patch)
treec911b2f8c24526ecdd1e105170e9dde660baa46b /testsuite/Makefile.am
parent7422e6ab359e05c9b350f6fce4ff57afe8dc1489 (diff)
* runtest.exp: Add new command line option, --status (or -st) to
toggle whether Tcl script bugs in test drivers should be propogated as an error to the shell. * lib/dejagnu.exp: Trim off test state part of the message, so we don't duplicate it.
Diffstat (limited to 'testsuite/Makefile.am')
-rw-r--r--testsuite/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/testsuite/Makefile.am b/testsuite/Makefile.am
index bbe2dbc..c206058 100644
--- a/testsuite/Makefile.am
+++ b/testsuite/Makefile.am
@@ -7,7 +7,7 @@ all: site.exp
RUNTEST = ` \
if [ -f ${top_srcdir}/runtest$(EXEEXT) ] ; then \
- echo ${top_srcdir}/runtest$(EXEEXT) ; \
+ echo ${top_srcdir}/runtest$(EXEEXT); \
else echo "ERROR: runtest not found" ; exit 1; fi`
RUNTESTDEFAULTFLAGS = --srcdir $$srcdir
@@ -21,7 +21,6 @@ site.exp: Makefile
@echo '## these variables are automatically generated by make ##' > $@-t
@echo '# Do not edit here. If you wish to override these values' >> $-t
@echo '# edit the last section' >> $@-t
- @echo 'set srcdir $(srcdir)' >> $@-t
@echo 'set objdir' `pwd` >> $@-t
@echo 'set tmpdir tmpdir' >> $@-t
@echo '## All variables above are generated by configure. Do Not Edit ##' >> $@-t
@@ -29,3 +28,6 @@ site.exp: Makefile
@test ! -f site.exp || mv site.exp site.bak
@mv $@-t site.exp
+
+
+