aboutsummaryrefslogtreecommitdiff
path: root/example/calc/Makefile.am
diff options
context:
space:
mode:
authorRob Savoye <rob@welcomehome.org>2001-05-06 16:22:20 +0000
committerRob Savoye <rob@welcomehome.org>2001-05-06 16:22:20 +0000
commitee37e3e22012ecee8b3d1d243378ce19a03689e3 (patch)
tree008acffabe6121789ecdc575da9aa8beee9565c6 /example/calc/Makefile.am
parentca94f15320ca1c1bd31020459f4751ab512b217c (diff)
* debian/rules: Install all the doc formats.release-1-4-1dejagnu-1.4.1-release
* redhat/dejagnu.spec: Install all the doc formats. * Clean.tcl: Also nuke all Emacs backup files. * Makefile.am: Fix dependencies on tarball target. Add new target to build Debian packages. Add $(includedir) to install-data-local target so dejagnu.h gets installed in the right place. * doc/Makefile.am: Make all paths absolute, cause some versions of the db2* tools are braindead. * doc/overview.sgml: Update version numbers and log. * doc/user.sgml: Add mention of dejagnu.h header file. * doc/ref.sgml: Add chapter on dejagnu.h header file for unit testing. * config/default.exp: New file for default config settings for simple native testsuites that don't need anything else. * lib/dejagnu.exp: Add $text\r\n to all strings, to make sure we only get one line at a time. * testsuite/libdejagnu: New directory for dejagnu library test cases. * testsuite/libdejagnu/unit.cc: Test case for dejagnu.h. * testsuite/libdejagnu/tunit.exp: Test driver for dejagnu.h. * testsuite/libdejagnu/Makefile.am: New makefile to build the test case. * testsuite/libdejagnu/Makefile.in: Generated. * testsuite/Makefile.am: Add libdejagnu to SUBDIRS. Replace the site.exp rule, cause we don't want the $tool setting, so we run all the test suites. Don't pass the tool name for "make check". * configure.in: Add testsuite/libdejagnu/Makefile to AC_OUTPUT.
Diffstat (limited to 'example/calc/Makefile.am')
-rw-r--r--example/calc/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/example/calc/Makefile.am b/example/calc/Makefile.am
index 4767579..454b2b8 100644
--- a/example/calc/Makefile.am
+++ b/example/calc/Makefile.am
@@ -17,7 +17,7 @@
AUTOMAKE_OPTIONS = dejagnu
-bin_PROGRAMS = calc
+noinst_PROGRAMS = calc
calc_SOURCES = calc.c
RUNTESTDEFAULTFLAGS = --tool calc CALC=`pwd`/calc --srcdir $$srcdir/testsuite \ No newline at end of file