aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRob Savoye <rob@welcomehome.org>2001-04-06 15:58:26 +0000
committerRob Savoye <rob@welcomehome.org>2001-04-06 15:58:26 +0000
commit67f23aa1c6cbc0d31adfed48dbbf0b140b4bcc12 (patch)
tree73cff2319a769840816a92544cfc179c822aac64 /Makefile.am
parent6280bb2cdb1ecc93f13098a026c323bea07de6f5 (diff)
* Makefile.am: Add an empty check-DEJAGNU target, cause we only
want to run the testsuite once. * example/Makefile.am: Don't run "calc" as part of check target, cause calc is just an example. * testsuite/Makefile.am: Use the runtest in the source tree, or refuse to run.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am23
1 files changed, 19 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 4b93a73..fd05622 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,11 @@ RUNTESTDEFAULTFLAGS = --tool runtest --srcdir $(srcdir)/testsuite RUNTEST=$(RUNT
RUNTEST = ` \
if [ -f ${srcdir}/runtest$(EXEEXT) ] ; then \
echo ${srcdir}/runtest$(EXEEXT) ; \
- else echo runtest ; fi`
+ else echo "ERROR: runtest not found" ; exit 1; fi`
+
+CLEANFILES = x.log x.sum site.bak setval.tmp
+check-DEJAGNU:
+ @echo "Do nothing here, cause we don't want to run the tests twice"
# Set ourselves up to build a RedHat package
dist2: rpmspec overview.html
@@ -32,9 +36,9 @@ dist2: rpmspec overview.html
(cd dejagnu-${VERSION}.0 ; $(srcdir)/Clean.tcl)
-mkdir -p doc/overview
-cp -fr doc/overview dejagnu-${VERSION}.0/doc/
- tar cvf ../dejagnu-${VERSION}.tar dejagnu-${VERSION}.0
- gzip -9fv ../dejagnu-${VERSION}.tar
- cp -f ../dejagnu-${VERSION}.tar.gz /usr/src/redhat/SOURCES/
+ tar cvf ../dejagnu-${VERSION}.0.tar dejagnu-${VERSION}.0
+ gzip -9fv ../dejagnu-${VERSION}.0.tar
+ cp -f ../dejagnu-${VERSION}.0.tar.gz /usr/src/redhat/SOURCES/
cp -f $(srcdir)/redhat/dejagnu.spec /usr/src/redhat/SPECS/
rpmspec:
@@ -97,3 +101,14 @@ uninstall-local:
test ! -f "$$f" || rm -f $(baseboards_dest)/`basename "$$f"`; \
done
+
+
+
+
+
+
+
+
+
+
+