aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorSaleem Abdulrasool <compnerd@compnerd.org>2018-08-20 22:50:18 +0000
committerSaleem Abdulrasool <compnerd@compnerd.org>2018-08-20 22:50:18 +0000
commitf02e4f90749b748f14c86a67803492eae4f94591 (patch)
tree78c84d214a8ff0a869243b6f44829b0e7d4e196d /clang/CMakeLists.txt
parentaccb51152c7b363d0bf3b7dad0b740fbb09d3a76 (diff)
libclang: add install/distribution targets for python
Add installation support for the python bindings for libclang. Add an additional CMake configuration variable to enumerate the python versions for which the bindings should be installed. This allows for a LLVM/clang distribution to distribute the python bindings for libclang as part of the image. Because the python versions need to be explicitly stated by the user, the default image remains unchanged. llvm-svn: 340228
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index 52b881939499..7e2762b6d5f1 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -279,6 +279,9 @@ endif()
set(CLANG_VENDOR_UTI "org.llvm.clang" CACHE STRING
"Vendor-specific uti.")
+set(CLANG_PYTHON_BINDINGS_VERSIONS "" CACHE STRING
+ "Python versions to install libclang python bindings for")
+
# The libdir suffix must exactly match whatever LLVM's configuration used.
set(CLANG_LIBDIR_SUFFIX "${LLVM_LIBDIR_SUFFIX}")