aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-11-29 00:34:46 +0000
committerPetr Hosek <phosek@chromium.org>2017-11-29 00:34:46 +0000
commitd32e51e32252cf5ae7a12887c35fd0e0b5878a3b (patch)
treea748ac77b7474435f44ca9bfa1547a61b3ed5819 /clang/CMakeLists.txt
parentfbf7b3bf3e7756b3cb343a266899857e6f2668cb (diff)
[CMake] Support side-by-side checkouts in multi-stage build
Passthrough LLVM_ENABLE_{PROJECTS,RUNTIMES} to followup stages to support the side-by-side checkouts (aka monorepo layout). Differential Revision: https://reviews.llvm.org/D40258 llvm-svn: 319267
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index dac32b9cdd76..e27a718e41a1 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -603,7 +603,9 @@ if (CLANG_ENABLE_BOOTSTRAP)
LLVM_BINUTILS_INCDIR
CLANG_REPOSITORY_STRING
CMAKE_MAKE_PROGRAM
- CMAKE_OSX_ARCHITECTURES)
+ CMAKE_OSX_ARCHITECTURES
+ LLVM_ENABLE_PROJECTS
+ LLVM_ENABLE_RUNTIMES)
# We don't need to depend on compiler-rt if we're building instrumented
# because the next stage will use the same compiler used to build this stage.