aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorMichal Gorny <mgorny@gentoo.org>2018-10-11 11:58:14 +0000
committerMichal Gorny <mgorny@gentoo.org>2018-10-11 11:58:14 +0000
commitcdd23f221d84123272f380151e09358376541405 (patch)
tree80d066ddc712581025315c572516c60d47fa44c0 /clang/CMakeLists.txt
parentc37d16140a8e2ba36929a5b11b53d5477460b96c (diff)
[tests] Include Python binding tests in CMake rules
Add a new CMake rule check-clang-python to run the Python bindings' test suite, and include it in check-all. Differential Revision: https://reviews.llvm.org/D52840 llvm-svn: 344241
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index 61fd913a2a53..84984f75b5f8 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -502,6 +502,7 @@ if( CLANG_INCLUDE_TESTS )
)
endif()
add_subdirectory(utils/perf-training)
+ add_subdirectory(bindings/python/tests)
endif()
option(CLANG_INCLUDE_DOCS "Generate build targets for the Clang docs."