aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Bieneman <beanz@apple.com>2016-07-25 18:54:30 +0000
committerChris Bieneman <beanz@apple.com>2016-07-25 18:54:30 +0000
commitc486541fea5db3a329132949c61ecf443aac3aea (patch)
tree7d1fec74ffe80469df281fb49b2bde83db37be96 /clang/CMakeLists.txt
parent705f7775bb6c1863da2cbde59270d545653f00d6 (diff)
[CMake] Cleaning up some CMake warnings
In Bootstrap builds Clang logs some warnings. These are caused because Clang passes CLANG_STAGE and BOOTSTRAP_DEFAULT_PASSTHROUGH into the next stage's configuration. BOOTSTRAP_DEFAULT_PASSTHROUGH shouldn't be passed, so it is renamed to _BOOTSTRAP_DEFAULT_PASSTHROUGH, to prevent passthrough. CLANG_STAGE should be passed, so I've changed the code to log it if it is set outside the if(CLANG_ENABLE_BOOTSTRAP) block. This makes the variable always used, so the warning goes away. llvm-svn: 276674
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index 417b2c6af7a3..4916c5185d36 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -463,12 +463,15 @@ endif()
add_subdirectory(cmake/modules)
+if(CLANG_STAGE)
+ message(STATUS "Setting current clang stage to: ${CLANG_STAGE}")
+endif()
+
if (CLANG_ENABLE_BOOTSTRAP)
include(ExternalProject)
if(NOT CLANG_STAGE)
set(CLANG_STAGE stage1)
- message(STATUS "Setting current clang stage to: ${CLANG_STAGE}")
endif()
string(REGEX MATCH "stage([0-9]*)" MATCHED_STAGE "${CLANG_STAGE}")
@@ -526,7 +529,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
set(verbose -DCMAKE_VERBOSE_MAKEFILE=On)
endif()
- set(BOOTSTRAP_DEFAULT_PASSTHROUGH
+ set(_BOOTSTRAP_DEFAULT_PASSTHROUGH
PACKAGE_VERSION
LLVM_VERSION_MAJOR
LLVM_VERSION_MINOR
@@ -577,7 +580,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
endforeach()
# Populate the passthrough variables
- foreach(variableName ${CLANG_BOOTSTRAP_PASSTHROUGH} ${BOOTSTRAP_DEFAULT_PASSTHROUGH})
+ foreach(variableName ${CLANG_BOOTSTRAP_PASSTHROUGH} ${_BOOTSTRAP_DEFAULT_PASSTHROUGH})
if(${variableName})
string(REPLACE ";" "\;" value ${${variableName}})
list(APPEND PASSTHROUGH_VARIABLES