aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorShoaib Meenai <smeenai@fb.com>2018-11-08 00:29:33 +0000
committerShoaib Meenai <smeenai@fb.com>2018-11-08 00:29:33 +0000
commitbb997f07f39c656b88b8d497edfa514621878cfc (patch)
treed0d35d6bb6f37c0659f23a23d8d71ae81408f9d1 /clang/CMakeLists.txt
parent7681abdef238e2713c34f3d3a2a04983b2237892 (diff)
[clang] Set CMP0075 to new
Make the check_include_file* macros honor CMAKE_REQUIRED_LIBRARIES. This shouldn't cause any of the configuration checks to give different results, and I verified that a clean configure before and after this change resulted in identical CMake caches on my machine. The same change was done for LLVM in r346377. llvm-svn: 346378
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index 3f5c3ae2ac4f..0a0f885b2be2 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -1,5 +1,9 @@
cmake_minimum_required(VERSION 3.4.3)
+if(POLICY CMP0075)
+ cmake_policy(SET CMP0075 NEW)
+endif()
+
# If we are not building as a part of LLVM, build Clang as an
# standalone project, using LLVM as an external library:
if( CMAKE_SOURCE_DIR STREQUAL CMAKE_CURRENT_SOURCE_DIR )