aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2017-12-05 00:15:20 +0000
committerPetr Hosek <phosek@chromium.org>2017-12-05 00:15:20 +0000
commit5a34c34858020b6eb0fc6d5ba9c80f582d032c92 (patch)
tree5d4647751b04f07af384785d4ce711db43dc6122 /clang/CMakeLists.txt
parent6851c0c38ede7bd4d235b58d84a8c32f76e4541a (diff)
[CMake] Don't use comma as an alternate separator
Using comma can break in cases when we're passing flags that already use comma as a separator. Fixes PR35504. Differential Revision: https://reviews.llvm.org/D40762 llvm-svn: 319720
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index e27a718e41a1..884879851544 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -655,7 +655,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
foreach(variableName ${variableNames})
if(variableName MATCHES "^BOOTSTRAP_")
string(SUBSTRING ${variableName} 10 -1 varName)
- string(REPLACE ";" "," value "${${variableName}}")
+ string(REPLACE ";" "|" value "${${variableName}}")
list(APPEND PASSTHROUGH_VARIABLES
-D${varName}=${value})
endif()
@@ -671,7 +671,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
if("${${variableName}}" STREQUAL "")
set(value "")
else()
- string(REPLACE ";" "," value "${${variableName}}")
+ string(REPLACE ";" "|" value "${${variableName}}")
endif()
list(APPEND PASSTHROUGH_VARIABLES
-D${variableName}=${value})
@@ -699,7 +699,7 @@ if (CLANG_ENABLE_BOOTSTRAP)
USES_TERMINAL_CONFIGURE 1
USES_TERMINAL_BUILD 1
USES_TERMINAL_INSTALL 1
- LIST_SEPARATOR ,
+ LIST_SEPARATOR |
)
# exclude really-install from main target