aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorPetr Hosek <phosek@chromium.org>2018-06-11 20:59:31 +0000
committerPetr Hosek <phosek@chromium.org>2018-06-11 20:59:31 +0000
commit534a104317c675442e74065782aa88bc1f0c2f9b (patch)
treede72ca9a784cb16e882f25f4e0f1c649830b5463 /clang/CMakeLists.txt
parent3efdb7ce1946ebc10fb1f910f3edb7b69a47cdb0 (diff)
[CMake] Allow specifying extra dependencies of bootstrap stage
This allows adding additional bootstrap dependencies to the bootstrap compiler that may be needed by later stages. Differential Revision: https://reviews.llvm.org/D47355 llvm-svn: 334437
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index fc7a3889a7c1..ab81ec34b00d 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -583,6 +583,10 @@ if (CLANG_ENABLE_BOOTSTRAP)
endif()
endif()
+ if(CLANG_BOOTSTRAP_EXTRA_DEPS)
+ add_dependencies(clang-bootstrap-deps ${CLANG_BOOTSTRAP_EXTRA_DEPS})
+ endif()
+
add_custom_target(${NEXT_CLANG_STAGE}-clear
DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/${NEXT_CLANG_STAGE}-cleared
)