aboutsummaryrefslogtreecommitdiff
path: root/clang/CMakeLists.txt
diff options
context:
space:
mode:
authorAaron Ballman <aaron@aaronballman.com>2017-11-04 20:06:49 +0000
committerAaron Ballman <aaron@aaronballman.com>2017-11-04 20:06:49 +0000
commit3f8bad86269ef2cc5d552c559421104081900a68 (patch)
tree3c707710a209ddbaddf7293ffd55a3871fa2e7c1 /clang/CMakeLists.txt
parente89760cb29671a480eae25ef83bc7f740307fb9d (diff)
Move the clang-tblgen-targets project into the Misc folder on IDEs like Visual Studio rather than leave it in the root directory. NFC.
llvm-svn: 317419
Diffstat (limited to 'clang/CMakeLists.txt')
-rw-r--r--clang/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/clang/CMakeLists.txt b/clang/CMakeLists.txt
index 42d580077d87..563b33eae2e8 100644
--- a/clang/CMakeLists.txt
+++ b/clang/CMakeLists.txt
@@ -429,6 +429,7 @@ add_subdirectory(include)
# All targets below may depend on all tablegen'd files.
get_property(CLANG_TABLEGEN_TARGETS GLOBAL PROPERTY CLANG_TABLEGEN_TARGETS)
add_custom_target(clang-tablegen-targets DEPENDS ${CLANG_TABLEGEN_TARGETS})
+set_target_properties(clang-tablegen-targets PROPERTIES FOLDER "Misc")
list(APPEND LLVM_COMMON_DEPENDS clang-tablegen-targets)
# Force target to be built as soon as possible. Clang modules builds depend