aboutsummaryrefslogtreecommitdiff
path: root/simd/Makefile.am
diff options
context:
space:
mode:
authordcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-09-05 07:23:12 +0000
committerdcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-09-05 07:23:12 +0000
commitfe4e608c6ad35f6dfcd58b5f7b02eb1bcd9f166d (patch)
tree56b324e6186f46631b79c75097507b9e3f063ce1 /simd/Makefile.am
parentba2a6a9012014324379aeeb45ab18af8d2ff050a (diff)
The AltiVec code actually works on 32-bit PowerPC platforms as well, so change the "powerpc64" token to "powerpc". Also clean up the shift code, which wasn't building properly on OS X.
git-svn-id: svn://svn.code.sf.net/p/libjpeg-turbo/code/trunk@1406 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'simd/Makefile.am')
-rw-r--r--simd/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/simd/Makefile.am b/simd/Makefile.am
index 06dce03..c5213b8 100644
--- a/simd/Makefile.am
+++ b/simd/Makefile.am
@@ -70,9 +70,9 @@ libsimd_la_SOURCES = jsimd_mips.c jsimd_mips_dspr2_asm.h jsimd_mips_dspr2.S
endif
-if SIMD_POWERPC64
+if SIMD_POWERPC
-libsimd_la_SOURCES = jsimd_powerpc64.c jsimd_powerpc64_altivec.c
+libsimd_la_SOURCES = jsimd_powerpc.c jsimd_powerpc_altivec.c
libsimd_la_CFLAGS = -maltivec
endif