aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2013-01-18 23:42:31 +0000
committerdcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2013-01-18 23:42:31 +0000
commitbebb38d3efdeba0f1893c0c3bf74212873b977d8 (patch)
treecbb9c0fceb3e39c397f5509b7d842f9962c6c07b /configure.ac
parent8525b369cb6144802921c25bcc36a5431a29fab2 (diff)
Implement in-memory source/destination managers even when not emulating the libjpeg v8 API/ABI
git-svn-id: svn://svn.code.sf.net/p/libjpeg-turbo/code/trunk@913 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 23 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a3e748c..ae331cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,7 +121,6 @@ AC_SUBST(JPEG_LIB_VERSION_DECIMAL)
AC_MSG_RESULT([$JPEG_LIB_VERSION_DECIMAL])
AC_DEFINE_UNQUOTED(JPEG_LIB_VERSION, [$JPEG_LIB_VERSION], [libjpeg API version])
-AC_MSG_CHECKING([libjpeg shared library version])
AC_ARG_VAR(SO_MAJOR_VERSION, [Major version of the libjpeg-turbo shared library (default is determined by the API version)])
AC_ARG_VAR(SO_MINOR_VERSION, [Minor version of the libjpeg-turbo shared library (default is determined by the API version)])
if test "x$SO_MAJOR_VERSION" = "x"; then
@@ -136,9 +135,31 @@ if test "x$SO_MINOR_VERSION" = "x"; then
*) SO_MINOR_VERSION=0 ;;
esac
fi
-AC_MSG_RESULT([$SO_MAJOR_VERSION:$SO_MINOR_VERSION])
+
+# Memory source/destination managers
+SO_AGE=0
+MEM_SRCDST_FUNCTIONS=
+if test "x${with_jpeg8}" != "xyes"; then
+ AC_MSG_CHECKING([whether to include in-memory source/destination managers])
+ AC_ARG_WITH([mem-srcdst],
+ AC_HELP_STRING([--without-mem-srcdst], [Do not include in-memory source/destination manager functions when emulating the libjpeg v6b or v7 API/ABI]))
+ if test "x$with_mem_srcdst" != "xno"; then
+ AC_MSG_RESULT(yes)
+ AC_DEFINE([MEM_SRCDST_SUPPORTED], [1], [Support in-memory source/destination managers])
+ SO_AGE=1
+ MEM_SRCDST_FUNCTIONS="global: jpeg_mem_dest; jpeg_mem_src;";
+ else
+ AC_MSG_RESULT(no)
+ fi
+fi
+
+AC_MSG_CHECKING([libjpeg shared library version])
+AC_MSG_RESULT([$SO_MAJOR_VERSION.$SO_AGE.$SO_MINOR_VERSION])
+SO_MAJOR_VERSION=`expr $SO_MAJOR_VERSION + $SO_AGE`
AC_SUBST(SO_MAJOR_VERSION)
AC_SUBST(SO_MINOR_VERSION)
+AC_SUBST(SO_AGE)
+AC_SUBST(MEM_SRCDST_FUNCTIONS)
AC_DEFINE_UNQUOTED(LIBJPEG_TURBO_VERSION, [$VERSION], [libjpeg-turbo version])