aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-02-05 08:15:44 +0000
committerdcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-02-05 08:15:44 +0000
commit6a9750fd3e77ed5f3cc415137486cb0d9b35bd36 (patch)
tree4cd6f8a618715c3856249c64505e7044fb7f6e38 /configure.ac
parenta99a2c2a5d5d23a08460b0ece52e0c64ab03a64e (diff)
First pass at ARMv8 64-bit NEON SIMD support
git-svn-id: svn://svn.code.sf.net/p/libjpeg-turbo/code/trunk@1108 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c327db5..6234641 100644
--- a/configure.ac
+++ b/configure.ac
@@ -430,7 +430,23 @@ if test "x${with_simd}" != "xno"; then
AC_MSG_ERROR([SIMD support can't be enabled.])
else
AC_MSG_WARN([SIMD support can't be enabled. Performance will suffer.])
+ fi
fi
+ ;;
+ aarch64*)
+ AC_MSG_RESULT([yes (arm64)])
+ AC_MSG_CHECKING([if the assembler is GNU-compatible and can be used])
+ AC_CHECK_COMPATIBLE_ARM64_ASSEMBLER_IFELSE(
+ [AC_MSG_RESULT([yes])
+ simd_arch=aarch64],
+ [AC_MSG_RESULT([no])
+ with_simd=no])
+ if test "x${with_simd}" = "xno"; then
+ if test "x${require_simd}" = "xyes"; then
+ AC_MSG_ERROR([SIMD support can't be enabled.])
+ else
+ AC_MSG_WARN([SIMD support can't be enabled. Performance will suffer.])
+ fi
fi
;;
mipsel*)
@@ -472,6 +488,7 @@ AM_CONDITIONAL([WITH_SSE_FLOAT_DCT], [test "x$simd_arch" = "xx86_64" -o "x$simd_
AM_CONDITIONAL([SIMD_I386], [test "x$simd_arch" = "xi386"])
AM_CONDITIONAL([SIMD_X86_64], [test "x$simd_arch" = "xx86_64"])
AM_CONDITIONAL([SIMD_ARM], [test "x$simd_arch" = "xarm"])
+AM_CONDITIONAL([SIMD_ARM_64], [test "x$simd_arch" = "xaarch64"])
AM_CONDITIONAL([SIMD_MIPSEL], [test "x$simd_arch" = "xmipsel"])
AM_CONDITIONAL([X86_64], [test "x$host_cpu" = "xx86_64" -o "x$host_cpu" = "xamd64"])
AM_CONDITIONAL([WITH_TURBOJPEG], [test "x$with_turbojpeg" != "xno"])