aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2010-01-28 05:34:53 +0000
committerdcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2010-01-28 05:34:53 +0000
commite357c8a7ef9f6208d3d99bbb74b1493f8ede63d1 (patch)
tree675249f255a3697ed05bf8b938b35a2dc3e2fc28 /Makefile.am
parent51537e9c1c3d2533da0c4933f2dc10bb88651c13 (diff)
Allow building libjpeg.so if --enable-shared is passed to configure (but disable shared library build by default)
git-svn-id: svn://svn.code.sf.net/p/libjpeg-turbo/code/trunk@71 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 26fe44c..bafa3d4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,13 @@
+if WITH_SHARED
+
+lib_LTLIBRARIES = libjpeg.la
+
+else
+
noinst_LTLIBRARIES = libjpeg.la
+
+endif
+
noinst_HEADERS = jconfig.h jerror.h jmorecfg.h jpeglib.h
HDRS = jchuff.h jdct.h jdhuff.h jerror.h jinclude.h jmemsys.h jmorecfg.h \