aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-08-22 03:04:06 +0000
committerdcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-08-22 03:04:06 +0000
commitc90bbc43e8a017b14a164b1a8a7116103dfb7884 (patch)
tree9ae11d655b9cc763e78655e0439a7b4112a20c0a /Makefile.am
parent82717761548d66e2dac8a9869687cf77ad7f5665 (diff)
Extend tjbenchtest so that it tests the dynamic JPEG buffer allocation feature in TurboJPEG. Disable the tiling feature in TJBench whenever dynamic buffer allocation is enabled (because the tiling feature requires a separate buffer for each tile, using it successfully with dynamic buffer allocation would require a separate TurboJPEG compressor instance for each tile, and it's not worth going to that trouble right now.)
git-svn-id: svn://svn.code.sf.net/p/libjpeg-turbo/code/trunk@1374 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index dad69df..e34f13e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -513,7 +513,9 @@ testclean:
tjtest:
sh ./tjbenchtest
+ sh ./tjbenchtest -alloc
sh ./tjbenchtest -yuv
+ sh ./tjbenchtest -yuv -alloc
if WITH_JAVA
sh ./tjbenchtest.java
sh ./tjbenchtest.java -yuv