aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2010-10-10 02:15:56 +0000
committerdcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2010-10-10 02:15:56 +0000
commitaec33c6d50fd41978b10dec7a9b1f5d007bd2c12 (patch)
tree85fe6a10da40c9a47b72eaec3d4cb7604c096667 /Makefile.am
parent3df8d49344adbe1ef89de065d4f7f9fcee9deb32 (diff)
Implement lossless crop feature from jpeg v7 and v8
git-svn-id: svn://svn.code.sf.net/p/libjpeg-turbo/code/trunk@243 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a87d77..ac8e65c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -118,6 +118,8 @@ test: testclean all
cmp $(srcdir)/testimgp.jpg testoutp.jpg
./jpegtran -outfile testoutt.jpg testoutp.jpg
cmp $(srcdir)/testimgint.jpg testoutt.jpg
+ ./jpegtran -crop 100x100+10+10 -transpose -perfect -outfile testoutcrop.jpg $(srcdir)/testorig.jpg
+ cmp $(srcdir)/testimgcrop.jpg testoutcrop.jpg
else
@@ -141,6 +143,8 @@ test: testclean all
cmp $(srcdir)/testimgp.jpg testoutp.jpg
./jpegtran -outfile testoutt.jpg testoutp.jpg
cmp $(srcdir)/testimgint.jpg testoutt.jpg
+ ./jpegtran -crop 100x100+10+10 -transpose -perfect -outfile testoutcrop.jpg $(srcdir)/testorig.jpg
+ cmp $(srcdir)/testimgcrop.jpg testoutcrop.jpg
endif