aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-05-07 06:02:57 +0000
committerdcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2014-05-07 06:02:57 +0000
commit3b0590534d6bb2bf6cb537585e154ac66e74dd4c (patch)
tree232de9ef2fc7c9d54ca8305360e4706cafe43ad5 /Makefile.am
parent7933ef15781b6d9d4459a6b0bb9f897923b3b436 (diff)
Fix regression that caused 'make test' to fail with non-x86 SIMD code. The round-off error in the SIMD float DCT/IDCT routines only exists in the SSE and SSE2 implementations.
git-svn-id: svn://svn.code.sf.net/p/libjpeg-turbo/code/trunk@1276 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f6f8e70..f14ddbf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -175,7 +175,10 @@ MD5_JPEG_GRAY_ISLOW = 72b51f894b8f4a10b3ee3066770aa38d
MD5_PPM_GRAY_ISLOW = 8d3596c56eace32f205deccc229aa5ed
MD5_PPM_GRAY_RGB_ISLOW = 116424ac07b79e5e801f00508eab48ec
MD5_JPEG_420S_IFAST_OPT = 388708217ac46273ca33086b22827ed8
-if WITH_SIMD
+# The SSE/SSE2 DCT/IDCT implementation has always produced a slight round-off
+# error relative to the C code, so in this case, we just test for regression
+# rather than verifying that the output matches libjpeg.
+if WITH_SSE_FLOAT_DCT
MD5_JPEG_3x2_FLOAT_PROG = 343e3f8caf8af5986ebaf0bdc13b5c71
MD5_PPM_3x2_FLOAT = 1a75f36e5904d6fc3a85a43da9ad89bb
else