aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authordcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2011-04-15 00:24:02 +0000
committerdcommander <dcommander@632fc199-4ca6-4c93-a231-07263d6284db>2011-04-15 00:24:02 +0000
commitc01ac0963a44223d3eb249c02adb0289c447388c (patch)
treeaaf16d5ced65969c555edb38f62d46da0c5d17d1 /CMakeLists.txt
parent2275ebfd2c158920b1526d71a2e2f145919c27ed (diff)
Use option() to handle configuration variables, so they will show up in the CMake GUI
git-svn-id: svn://svn.code.sf.net/p/libjpeg-turbo/code/trunk@577 632fc199-4ca6-4c93-a231-07263d6284db
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 6 insertions, 15 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c8850a6..62bfb6f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,17 +34,12 @@ endif()
message(STATUS "VERSION = ${VERSION}, BUILD = ${BUILD}")
-if(NOT DEFINED WITH_SIMD)
- set(WITH_SIMD 1)
-endif()
-
-if(NOT DEFINED WITH_ARITH_ENC)
- set(WITH_ARITH_ENC 1)
-endif()
-
-if(NOT DEFINED WITH_ARITH_DEC)
- set(WITH_ARITH_DEC 1)
-endif()
+option(WITH_SIMD "Include SIMD extensions" TRUE)
+option(WITH_ARITH_ENC "Include arithmetic encoding support" TRUE)
+option(WITH_ARITH_DEC "Include arithmetic decoding support" TRUE)
+option(WITH_JPEG7 "Emulate libjpeg v7 API/ABI (this makes libjpeg-turbo backward incompatible with libjpeg v6b)" FALSE)
+option(WITH_JPEG8 "Emulate libjpeg v8 API/ABI (this makes libjpeg-turbo backward incompatible with libjpeg v6b)" FALSE)
+option(WITH_JAVA "Build Java wrapper for the TurboJPEG/OSS library" FALSE)
if(WITH_ARITH_ENC)
set(C_ARITH_CODING_SUPPORTED 1)
@@ -60,10 +55,6 @@ else()
message(STATUS "Arithmetic decoding support disabled")
endif()
-if(NOT DEFINED WITH_JAVA)
- set(WITH_JAVA 0)
-endif()
-
if(WITH_JAVA)
message(STATUS "TurboJPEG/OSS Java wrapper enabled")
else()