summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVincent Guittot <vincent.guittot@linaro.org>2015-10-08 18:38:25 +0200
committerVincent Guittot <vincent.guittot@linaro.org>2015-10-21 10:46:35 +0200
commitac1a8443e27ab287fd12a21c5aa07377cf8ff3fe (patch)
treee7f54be55c9c4c1a51be7efe9644e8773999377b /configure.ac
parentc7daff743bc502abe2a44577d4f54168a753c0fe (diff)
rt-app: remove conditional dependency with libjson-c
rt-app can't run any more without using libjson-c since json file is the only way to provide the description of a use case Signed-off-by: Vincent Guittot <vincent.guittot@linaro.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 1 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index 50d6f76..6b24f11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12,6 +12,7 @@ AC_HEADER_STDC
AC_CHECK_LIB([pthread], [pthread_create])
AC_CHECK_LIB([m], [round])
AC_CHECK_LIB([rt], [clock_gettime])
+AC_CHECK_LIB([json-c], [json_object_from_file])
AC_ARG_WITH([deadline],
[AS_HELP_STRING([--with-deadline],
@@ -23,17 +24,6 @@ AS_IF([test "x$with_deadline" != xno],
[AC_DEFINE([DLSCHED], [1], [Define if you have SCHED_DEADLINE support])
])
-LIBJSON=
- AC_CHECK_LIB([json-c], [json_object_from_file],
- [AC_SUBST([LIBJSON], ["-ljson-c"])
- AC_DEFINE([JSON], [1], [Define if you have libjson-c])
- ],
- [AC_MSG_FAILURE([libjson-c test failed (use --without-json-c to disable or install json-c)])],
- [-ljson-c]
- )
-
-AM_CONDITIONAL([AMJSON], [ test x$with_json != xno])
-
AC_ARG_VAR([LOGLVL], [verbosity level, from 0 to 100. 100 is very verbose])
if test -z "${LOGLVL}";then