summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGiacomo Bagnoli <g.bagnoli@asidev.com>2010-03-01 17:06:10 +0100
committerGiacomo Bagnoli <g.bagnoli@asidev.com>2010-03-01 17:06:10 +0100
commit28531017925f2bf137a015afa67f50736b82e9e6 (patch)
treeec44f8c4d8bcd8c1676a1bc822003302067775ea /configure.ac
parent6f4e1a6bd5adb899aa68f3449e4e9291436be7d2 (diff)
Added support for --enable-lockmem and --enable-aquosa
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cc83ebc..d046366 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,15 @@ AC_HEADER_STDC
AC_CHECK_LIB([pthread], [pthread_create])
AC_CHECK_LIB([m], [round])
AC_CHECK_LIB([rt], [clock_gettime])
-AC_CHECK_LIB([qreslib], [qres_init])
+AC_ARG_ENABLE([lockmem], AS_HELP_STRING([--enable-lockmem],[lock all memory to avoid it being swapped out]))
+AC_ARG_ENABLE([aquosa], AS_HELP_STRING([--enable-aquosa], [Add support for the AQuoSA framework]))
+AS_IF([test "x$enable_lockmem" = "xyes"], [
+ AC_DEFINE([LOCKMEM], [], [lock all memory to avoid it being swapout])
+])
+AS_IF([test "x$enable_aquosa" = "xyes"], [
+ AC_CHECK_LIB([qreslib], [qres_init])
+])
+
AC_CONFIG_HEADERS([src/config.h])
AC_CONFIG_FILES([Makefile src/Makefile])
AC_OUTPUT