summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorVincent Guittot <vincent.guittot@linaro.org>2015-10-09 11:59:09 +0200
committerVincent Guittot <vincent.guittot@linaro.org>2015-10-23 08:54:44 +0200
commit643ef9e8f8777e55815430f4d778ffd4a83c143b (patch)
tree7fe13f2945d008ef95c916a4e7dcb1515c251386 /Makefile.am
parentac1a8443e27ab287fd12a21c5aa07377cf8ff3fe (diff)
rt-app: conditionally compile libdl
sched_setattr syscall has been added in v3.14 with deadline scheduler. This new syscall is not always implemented in the lib and libdl is used in this case. We add a test on the presence of sched_setattr in the system environment and compile libdl iff sched_setattr has not been already defined by another library Signed-off-by: Vincent Guittot <vincent.guittot@linaro.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3e4d129..ad50fa0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1 +1,6 @@
+if SET_DLSCHED
SUBDIRS = libdl src
+else
+SUBDIRS = src
+endif
+